PWCforums.co.uk Homepage

  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Seadoo Limp Mode

 Post Reply Post Reply
Author
4213paul View Drop Down
Skilled Skier
Skilled Skier
Avatar

Joined: 03/Sep/2009
Location: Hampshire
Status: Offline
Points: 24
Post Options Post Options   Thanks (0) Thanks(0)   Quote 4213paul Quote  Post ReplyReply Direct Link To This Post Topic: Seadoo Limp Mode
    Posted: 07/Jul/2010 at 10:43pm
Hi All, Fist post in tech hope someone here can help, My son owns a 2001 seadoo gtx di, seems to be running in limp mode, Had it plugged in and they said it was charging fault. They tried rectifier/regulator then said it was stator fault, Took ski home as was told stator removal was an engine out job (not true) checked stator found washer from bolt holding bendix bracket on magnet. cleaned stator/magnet refitted bolt and washer rebuilt and tried, Still not charging. Fitted new rectifier/regulator from states (Third of the price we were quoted) now charging fine. But still have original problem, Ski starts and ticks over fine, As soon as you accelerate the maint light comes on and engine revs will not exceed approx 3000, Any ideas where to look next?  pls help!!! Thanks Paul
Ps Have cleaned rave valves and checked rave solenoid all ok.SmileSmileSmile
Back to Top
Macca View Drop Down
Post Whore
Post Whore
Avatar

Joined: 16/Jun/2006
Status: Offline
Points: 1832
Post Options Post Options   Thanks (0) Thanks(0)   Quote Macca Quote  Post ReplyReply Direct Link To This Post Posted: 09/Jul/2010 at 7:58pm
I had the same model ski that went in to limp mode, not due to electrical problems but due to dirty grease around the TPS (throttle position sensor), cleaned off, fault reset and that was it, sorted.
Back to Top
Stuart_ View Drop Down
Senior Member
Senior Member
Avatar

Joined: 11/Jun/2007
Location: Essex
Status: Offline
Points: 345
Post Options Post Options   Thanks (0) Thanks(0)   Quote Stuart_ Quote  Post ReplyReply Direct Link To This Post Posted: 10/Jul/2010 at 8:02am
hi, i had a seadoo xp di, which would all ways go in to limp mode, i replaces both air injectors and the knock sensor, sane fault still there plugged it on a machine, again and this time it showed up the rave valves solenoid, and worked again.

can you get it plugged on to a seadoo computer?

stu
seadoo 2010 rxp x 255rs
Yamaha 2009 fzs
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.391 seconds.